OS compatibility

The application is compatible with iOS 8+ and Android from 4.0.3.

Still need help? Contact Us Contact Us